[whatwg] The "form" attribute

Hallvord R M Steen hallvors at gmail.com
Tue Aug 10 09:45:16 PDT 2004

On Fri, 30 Jul 2004 12:00:00 +0200, Olav Junker Kjær <olav at olav.dk> wrote:

>  I propose that the "form" attribute is renamed
> to avoid clash with the "form" property in the DOM. (I cant think of a
> good name, though). The new attribute should have a corresponding DOM
> property of type DOMString.

Perhaps it should be called parentForm (though that suggests too
strongly that the form is an actual parent in the DOM hierarchy) or

Actually, it might be useful to allow an element to belong to more
than one form. What about a space-separated list of forms the way
"class" can be done today?
Hallvord R. M. Steen

More information about the whatwg mailing list