[whatwg] Re: Canvas tag
Ian Hickson
ian at hixie.ch
Mon Aug 16 18:55:10 PDT 2004
On Tue, 13 Jul 2004, Erik Arvidsson wrote:
>
> After some digging in the webcore source files online at
> http://www.opensource.apple.com/darwinsource/WWDC2004/WebCore-146.1/ I found
> the following methods on the Context2D object which you get from the canvas
> element [...]
Based on this and also these files from mozilla.org:
http://lxr.mozilla.org/mozilla/source/layout/xul/base/src/nsCanvasFrame.cpp
http://lxr.mozilla.org/mozilla/source/layout/xul/base/src/nsCanvasFrame.h
http://lxr.mozilla.org/mozilla/source/layout/xul/base/src/nsCanvasRenderingContext2D.cpp
http://lxr.mozilla.org/mozilla/source/layout/xul/base/public/nsICanvasBoxObject.idl
http://lxr.mozilla.org/mozilla/source/layout/xul/base/public/nsICanvasRenderingContext2D.idl
...I drafted up an initial version of the <canvas> spec:
http://whatwg.org/specs/web-apps/current-work/#graphics
I urge people to send comments to this list. I'm not a graphics expert, so
in particular anything that uses drawing terminology might well be wrong.
Some open questions to get people started: What should happen if the width
and height attributes are mutated? Should shadowOffsetX should be renamed
to shadowOffsetWidth? How should globalCompositeOperation work? Should
fillRect() reset the current path?
--
Ian Hickson U+1047E )\._.,--....,'``. fL
http://ln.hixie.ch/ U+263A /, _.. \ _\ ;`._ ,.
Things that are impossible just take longer. `._.-(,_..'--(,_..'`-.;.'
More information about the whatwg
mailing list