[whatwg] Menus, fallback, and backwards compatibility: ideas wanted

Ian Hickson ian at hixie.ch
Tue Dec 13 15:10:56 PST 2005

On Tue, 13 Dec 2005, Matthew Raymond wrote:
>    Hmm. The name "context" as a menu |type| is more semantic, but less 
> accurate in non-context-menu cases, such as popup menus and submenus. 
> The name "popup" is more general, but more presentational.

I'm not attached to "context". (I'm not particularly fond of "popup", 
though). What I really want is an attribute whose values convey "acts as a 
ul with no magic", "declares a menu for use elsewhere", and "turns into a 
toolbar, menu bar, or other command list displayed inline".

Ian Hickson               U+1047E                )\._.,--....,'``.    fL
http://ln.hixie.ch/       U+263A                /,   _.. \   _\  ;`._ ,.
Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'

More information about the whatwg mailing list