[whatwg] Web Forms 2 stable draft draft
ian at hixie.ch
Mon Feb 7 15:20:49 PST 2005
On Mon, 7 Feb 2005, [ISO-8859-1] Olav Junker Kjær wrote:
> You write:
> > The model used by the validity DOM attribute is not very clean, and
> > may deserve to be replaced with something that has been thought
> > through with more care
> Perhaps the bit field interface could be left out.
Yeah, I'm considering it. My main reason not to just do it is that it
would require _massive_ changes to the draft (everything is currently
defined in terms of the bit masks, and the object is then defined in
terms of that).
> A better solution would perhaps be to add an attribute, "isValid" to
> ValidationState. So you could write:
> if (field1.validity.isValid) ...
> Only problem is that the naming seems a bit strange. "validityState"
> would be clearer than "validity", but also a bit more cumbersome.
That's pretty much the line of thought I had on the matter.
> Anyway, it seems a bit redundant to support both the bit field and
> property interfaces.
I agree. Hence the comment in the status section. :-)
Ian Hickson U+1047E )\._.,--....,'``. fL
http://ln.hixie.ch/ U+263A /, _.. \ _\ ;`._ ,.
Things that are impossible just take longer. `._.-(,_..'--(,_..'`-.;.'
More information about the whatwg