[whatwg] Web Forms 2.0 - repetition model control

Ian Hickson ian at hixie.ch
Wed Oct 26 11:04:17 PDT 2005

On Sat, 15 Oct 2005, ROBO Design wrote:
> You've made a mistake in the spec note you added :).
> > Note: Four other new types, add, remove, move-up and move-down, have 
> > been introduced. They are defined are part of <the repeating form 
> > controls model>.
> Correction:
> > Note: Four other new types, add, remove, move-up and move-down, have 
> > been introduced. They are part of <the repetition model for repeating 
> > form controls>.

The section titled "the repetition model for repeating form controls" 
defines the "repeating form controls model" (that term is in bold in the 
intro to that section), so I don't see what the problem is.

> Last, but not least, I must emphase that 'ease of typing' (or short 
> attributes and tags) should not take over. This is because the 
> specification may 'suffer' in the future, when new versions will be 
> written. You should think of 'what if I will add something which also 
> uses those keywords?'.

I agree it is a balancing act. <address> probably went too far for 
instance (since it isn't for any address). But type="add" seems reasonably 
clear to me.

> Another reason for not being 'afraid' of having the code more 
> 'talkative' is that people use specialized editors with auto-complete or 
> WYSIWYG editors. Therefore, the amount of chars needed to type ain't 
> really that high.

Actually in practice a lot of HTML is hand-written in tools like Notepad.

> Why not leave the type= attribute alone and make better use of 
> template=. How:
> 1. template="add|remove|move-up|move-down"
> This behaves exactly as <input type="add|remove|move-up|move-down">
> Note: without any specific declaration of a template ID.
> 2. template="some-ID;(add|remove|move-up|move-down)"
> See where I am going? This would behave as <input
> type="add|remove|move-up|move-down" template="some-ID">

I don't see the advantage of that. It makes it harder to implement, easier 
to get wrong, and doesn't seem to have any big benefit over the current 

> What would probably be better:
> <input type="template" for="some-template-ID"
> action="add|remove|move-up|move-down">
> Now, I know what you are thinking: that this suggestion adds even more 
> chars for the devs to type, but this would probably better than the 
> previous suggestion, since implementation is more straight forward and 
> there's also better readability of the code.

It's easier to implement than your earlier suggestion, but I don't really 
see any advantage to the authors.

> Going back and reviewing all of the 3 suggestions ... first was the 
> best: type="template-add". The second one requires less typing for web 
> developers. Each suggestion has its weakness and strength.
> As a conclusion, any of the 3 above would be better than what's 
> currently in the spec. I really believe something should be done (if I 
> am not too late)... this was the only thing that really seemed 
> 'bad'/wrong immediately after reading.

I guess I'm not convinced that we will have a problem if we go with the 
current names.

Ian Hickson               U+1047E                )\._.,--....,'``.    fL
http://ln.hixie.ch/       U+263A                /,   _.. \   _\  ;`._ ,.
Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'

More information about the whatwg mailing list