[whatwg] proposed canvas 2d API additions

Ian Hickson ian at hixie.ch
Wed Apr 26 13:15:31 PDT 2006


On Sat, 22 Apr 2006, Sjoerd Visscher wrote:
> Ian Hickson wrote:
> > On Sat, 22 Apr 2006, Sjoerd Visscher wrote:
> > > > I understand what you are proposing. What I don't understand is what
> > > > colour should be returned when the many device pixels represented by the
> > > > given coordinate space pixel have different colors.
> > > The weighted average of the colors in the square the size of 1 by 1 canvas
> > > pixels.
> > 
> > ...in fact, that won't work. It would mean that this, which should be a
> > no-op:
> > 
> >    c.putPixels(c.getPixels(x, y, width, height), x, y, width, height);
> > 
> > ...will end up down-sampling the bitmap, which seems like it would break the
> > main use case for this API.
> 
> If this is the main use case, then putPixels is just drawImage, and 
> getPixels should be called copyCanvas, with the 4 arguments just setting 
> a clip region.

Vlad suggested the use case was sightly more complex, basically:

   c.putPixels(manipulate(c.getPixels(...)), ...);


> The main use case of calculating the color of a (pixel-)square whould be 
> the eye drop tool.

You could manually do this using the API I suggested earlier today, FWIW, 
including handling transparency in special ways.

-- 
Ian Hickson               U+1047E                )\._.,--....,'``.    fL
http://ln.hixie.ch/       U+263A                /,   _.. \   _\  ;`._ ,.
Things that are impossible just take longer.   `._.-(,_..'--(,_..'`-.;.'



More information about the whatwg mailing list