gerv at mozilla.org
Mon Mar 20 02:31:12 PST 2006
Douglas Crockford wrote:
> The JSONRequest does only one thing:
Are you planning to take the excellent advice from <I forget who> to
change the name? The name XmlHttpRequest sucks because it doesn't
necessarily return XML, and it doesn't have to be over HTTP. Let's not
tie the name of a new thing solely to the way we use it at the moment.
Why not just call it "Request", and have an API to set the Accept:
header, so people can set it to "application/json"? You could even make
that the default.
More information about the whatwg