[whatwg] proposed canvas 2d API additions
Arve Bersvendsen
arveb at opera.com
Tue May 16 02:30:17 PDT 2006
On Tue, 16 May 2006 10:25:01 +0200, Vladimir Vukicevic
<vladimirv at gmail.com> wrote:
> On 4/26/06, Ian Hickson <ian at hixie.ch> wrote:
>> ImageData getImageData(in float x, in float y, in float w, in float
>> h);
>> void drawImageData(in float x, in float y, in ImageData d);
>
> I'm about to implement this as suggested; however, I'd call the second
> function here "putImageData" instead of "drawImageData"; draw implies
> an actual drawing operation, similar to drawImage, that would be
> affected by (at least) the current compositing operator.
Again, and this goes back to what's already been said about the RGBA
values in ImageData: Using floats for x,y,w,h will for all practical
purposes exclude canvas from ever being possible to implement in a
meaningful way on systems without hardware FPUs.
I realise that we can go on forever debating whether having an API that
"facilitates data loss" is good or bad, but the fact is that it is
possible for authors to code around this, and get enough performance to
perform on weaker devices.
--
Arve Bersvendsen, Opera Software ASA
More information about the whatwg
mailing list