[whatwg] <video>: togglePause() versus pause()
magnusrk+whatwg at pvv.org
Sun Mar 18 14:09:02 PDT 2007
On Sun, 18 Mar 2007 22:00:33 +0100, Anne van Kesteren <annevk at opera.com>
> I just played some more with our internal implementation (Opera's) and
> noticed that our pause() really is like togglePause() in the HTML5
> proposal. Looking at the specification I don't see much need for pause()
> there. Perhaps togglePause() should just become pause() and pause() be
I would suggest the opposite. For basic actions like play and pause,
play() and pause() are the most natural options. I question whether we
need a command to toggle between play/pause at all. Any UI which uses a
combined play/resume button has to know which state it is, so it already
knows which command is relevant.
"Don't worry; the Universe IS out to get you."
More information about the whatwg