[whatwg] several messages about the naming of the loop attributes

Michael A. Puls II shadow2531 at gmail.com
Sat Oct 27 17:59:26 PDT 2007

On 10/26/07, Ian Hickson <ian at hixie.ch> wrote:
> Bikeshed alert.
> On Fri, 19 Oct 2007, Michael A. Puls II wrote:
> > Now, I am suggesting:
> > currentLoop -> playIndex || currentPlayIndex || currentPlayCountIndex
> I have left this one for now. I don't like index, for reasons discussed
> below.

I see your point.

It's difficult to find something without 'loop' in it that's better
than currentLoop. Maybe that's a good sign.

> On Fri, 19 Oct 2007, Simon Pieters wrote:
> >
> > I don't have an opinion about naming in general, but I will note that
> > .playIndex is consistent with <select>'s .selectedIndex.
> For me this counts as a point against -- the selectedIndex identifies an
> item in a list, whereas here we are identifying a general period of time.


More information about the whatwg mailing list