[whatwg] Significant changes to globalStorage
ian at hixie.ch
Sat Feb 9 01:14:36 PST 2008
On Fri, 11 Jan 2008, Dave Camp wrote:
> On Dec 10, 2007, at 5:46 PM, Ian Hickson wrote:
> > I just checked in a change to make globalStorage far simpler -- I
> > dropped all the domain manipulation stuff, and made it same-origin
> > instead. I also dropped StorageItem and just made the Storage stuff
> > return strings.
> Perhaps the new globalStorage object should be renamed while making this
> change? This will let us deprecate globalStorage a bit more gracefully
> (clients checking for its existence won't get an object that behaves
> differently than expected).
> Perhaps "localStorage"?
> That still won't help users of StorageItem.value, but it might be useful
I love the irony of the fact that we just renamed _global_ storage to
_local_ storage without changing anything of the semantics...
Ian Hickson U+1047E )\._.,--....,'``. fL
http://ln.hixie.ch/ U+263A /, _.. \ _\ ;`._ ,.
Things that are impossible just take longer. `._.-(,_..'--(,_..'`-.;.'
More information about the whatwg