[whatwg] activedescendant in viewport (Re: scrollIntoView jarring?)

Aaron Leventhal aaronlev at moonset.net
Fri May 2 12:10:03 PDT 2008

I think if there is an attribute like this which also scrolls for you, 
then it should be called activedescendant, not aria-activedescendant. I 
don't see a problem if HTML 5 wants the attribute without aria- to drive 
browser behavior. In that case perhaps it should style the active 
descendant to it is active somehow.

In general it's easier to explain ARIA if there are some consistent 
principles, such as, it doesn't drive browser behavior. It just allows 
the JS developer to report what they did. And since the widgets also 
need to work in older browsers that don't support ARIA, it's better if 
the aria- attributes maintain that rule.

Otherwise, without that rule, it really is a slippery slope. First we 
have aria-activedescendant scroll for you, so why not show it is active 
for you? Why shouldn't aria-disabled actually make the item disabled? 
Etc. etc. Pretty soon we're implementing the widgets for the author and 
none of it works most browsers.

- Aaron

More information about the whatwg mailing list