[whatwg] XXX-Origin header
bil at corry.biz
Thu Apr 2 21:15:14 PDT 2009
Since the public-webapps list was never able to reconcile HTML5's Origin header (now renamed XXX-Origin) with CORS's Origin header, we're left with two headers with similar implementations and similar names. Due to this, it may prudent to rename XXX-Origin to something without "Origin" in the name to better distinguish between the two. I don't know what the header should be renamed to ("Source"?), but no matter which name is chosen for the header, it should be listed as a prohibited header for XHR.setRequestHeader().
More information about the whatwg