[whatwg] Storage mutex feedback
mikewse at hotmail.com
Mon Aug 31 08:54:08 PDT 2009
Jonas Sicking wrote:
> On Sat, Aug 29, 2009 at 10:06 PM, Ian Hickson<ian at hixie.ch> wrote:
> > Upon further consideration I've renamed getStorageUpdates() to
> > yieldForStorageUpdates().
> I really liked Darin's (?) suggestion of allowStorageUpdates as that
> seems to exactly describe the intended use of the function. We no
> longer prevent other page from updating the storage.
Quite nice. One little nit is that it could be
interpreted as allowing oneself's updates, while
it is really about allowing other's updates.
allowOtherStorageUpdates? (not so nice, but... ;-)
Is there a preference for having the name indicate
that "we" are finishing our own transaction, ie
or should it indicate that "others" are now welcome
to do their stuff, such as in:
More information about the whatwg