[whatwg] fileList vs files

Jonas Sicking jonas at sicking.cc
Thu Mar 26 22:04:34 PDT 2009

On Thu, Mar 26, 2009 at 8:26 PM, Biju <bijumaillist at gmail.com> wrote:
>   I have a poor memory,
>   hence not good in spelling,
>   if there is not much gain with a change,
>   i wish every thing follow a similar pattern
>   and with short spelling,
>   which make my life little easier.
> <<<
> On "C:\fakepath\" in HTML5 thread Anne mentioned "fileList" for <input
> type=file multiple>
> On Tue, Mar 24, 2009 at 10:15 AM, Anne van Kesteren <annevk at opera.com> wrote:
>> application developers...) Furthermore, once we get interoperable support
>> for <input type=file multiple> and the fileList proposal starts moving we
> Can we call it "files" instead of fileList, this will make it
> consistent with existing names like
> arguments
> document.links
> selection_element.options
> document.plugins
> document.embeds
> document.anchors
> document.forms
> document.applets
> document.images
> on firefox we fixed it
> https://bugzilla.mozilla.org/show_bug.cgi?id=405741

I agree that the property should be called .files. However given that
we don't have any property at all specced yet, it feels a little bit
early to start debating the name :)

/ Jonas

More information about the whatwg mailing list