[whatwg] rename CanvasPixelArray

Anne van Kesteren annevk at opera.com
Mon May 4 06:36:06 PDT 2009

On Fri, 01 May 2009 01:10:19 +0200, Ian Hickson <ian at hixie.ch> wrote:
> I haven't renamed it. I don't think it's a big deal to introduce other
> interfaces that look the same but with different names, if we need to.

I agree that's not a problem, but the asymmetry between ImageData and CanvasPixelArray would be nice to avoid. (I'd be fine with renaming ImageData to CanvasData as well.)

Anne van Kesteren

More information about the whatwg mailing list