[whatwg] insertAdjacentHTML

Daniel Glazman daniel.glazman at disruptive-innovations.com
Tue Nov 24 07:01:26 PST 2009

Hi there,

I think that insertAdjacentHTML as defined in current section 3.5.7 [1]
could be much cleaner and clearer if

1 - "Adjacent" was dropped. It's useless. The name could be insertHTML.

2. if the values were "before", "firstchild", "lastchild", after"
    instead of the current "beforebegin", "afterbegin", "beforend" and
    "afterend" that seem to me visually related to start and end tags
    and not the element itself. Consistency with the existing DOM
    phraseology seems to me useful.



More information about the whatwg mailing list