[whatwg] several messages
ian at hixie.ch
Thu Sep 3 04:41:25 PDT 2009
On Mon, 31 Aug 2009, Jonas Sicking wrote:
> > Upon further consideration I've renamed getStorageUpdates() to
> > yieldForStorageUpdates().
> 'yield' usually refers to halting execution. I would expect the above
> name to stop the current thread and allow other threads to run. While
> that is what could be happening here, I'm not sure that is the primary
> function of the call.
It's more or less exactly what the method does, no?
> I really liked Darin's (?) suggestion of allowStorageUpdates as that
> seems to exactly describe the intended use of the function. We no longer
> prevent other page from updating the storage.
"allow" implies a state change, which I don't think really matches what is
happening here. ("How do I disallow updates?")
On Mon, 31 Aug 2009, Mike Wilson wrote:
> Is there a preference for having the name indicate
> that "we" are finishing our own transaction, ie
> or should it indicate that "others" are now welcome
> to do their stuff, such as in:
I think we want more the second, but with shorter names.
Ian Hickson U+1047E )\._.,--....,'``. fL
http://ln.hixie.ch/ U+263A /, _.. \ _\ ;`._ ,.
Things that are impossible just take longer. `._.-(,_..'--(,_..'`-.;.'
More information about the whatwg