[whatwg] Adding FormData support to <form>

Jonas Sicking jonas at sicking.cc
Thu Feb 18 18:20:38 PST 2010

On Thu, Feb 18, 2010 at 5:30 PM, Robert O'Callahan <robert at ocallahan.org> wrote:
> On Fri, Feb 19, 2010 at 1:52 PM, Ian Hickson <ian at hixie.ch> wrote:
>> toDataURL() was named that way for consistency with toString(), which
>> seems a closer analogue here than getElementById() and friends.
> <bikeshed>
> But you're not really converting the form element into something equivalent,
> are you? That's what "to" methods usually imply, IMHO. Maybe it should be
> "createFormData" or "extractFormData"?
> </bikeshed>

This was my reasoning too.

I'm not a big fan of 'createFormData' as to me it doesn't sound like
it'll also populate the FormData with the current values. Possibly due
to the similarity with 'createElement'. 'extractFormData' sounds ok
though, though i think 'getFormData' is nicer due to its shorter name.

/ Jonas

More information about the whatwg mailing list