[whatwg] Feedback on UndoManager spec
rniwa at webkit.org
Wed Nov 30 18:00:47 PST 2011
On Wed, Nov 30, 2011 at 5:38 PM, Jonas Sicking <jonas at sicking.cc> wrote:
> I actually think it's actively bad to converge on having the same
> interface for automatic and manual transaction. The two work in
> dramatically different ways. The code that goes into the "apply"
> function of a automatic transaction has dramatically different meaning
> than the code that goes into the "apply" function for a manual
> transaction since the UA records the actions of the former and stores
> them away.
Okay. I'm actually renaming apply, unapply, reapply to execute, undo, and
redo. So how about "automaticExecute"?
More information about the whatwg