eric.carlson at apple.com
Sat Oct 15 13:05:34 PDT 2011
On Oct 15, 2011, at 2:05 AM, Olli Pettay wrote:
> On 10/15/2011 07:27 AM, Anne van Kesteren wrote:
>> I went with "fullscreen" rather than "full screen" as that seemed
>> cleaner and easier to type. I also used "enter" and "exit" rather than
>> "request" and "cancel" as they seemed somewhat nicer too. I'm less
>> attached to this latter change though.
> To me "enterFullscreen()" sounds like something which couldn't fail.
> "requestFullscreen()" is closer to what actually happens: script asks
> UA to go to fullscreen mode, but it may fail if user or UA for some
> reason denies the request.
I agree. "requestFullscreen" describes what happens much more accurately.
More information about the whatwg