[whatwg] Fixing undo on the Web - UndoManager and Transaction

Ryosuke Niwa rniwa at webkit.org
Sun Sep 11 19:00:21 PDT 2011

On Tue, Aug 30, 2011 at 12:15 PM, Ryosuke Niwa <rniwa at webkit.org> wrote:
> 4. Jonas requested that we have manualTransact and managedTransact instead
> of single transact on undoManager for clarity.  I think this is a good idea
> but I'd rather settle the naming issue first.

 If we're making this change (presumably, automaticTransact and
manualTransact), then it seems odd that both of them take the Transaction
interface because "apply" is required while "unapply" and "reapply" are
ignored for automaticTransact, but they're all optional for manualTransact.

Should we also split the interface into AutomaticTransaction interface and
ManualTransaction interface?

- Ryosuke

More information about the whatwg mailing list