[whatwg] Fixing undo on the Web - UndoManager and Transaction

Jonas Sicking jonas at sicking.cc
Mon Sep 12 17:15:18 PDT 2011

On Mon, Sep 12, 2011 at 1:31 PM, Ehsan Akhgari <ehsan at mozilla.com> wrote:
> On 11-09-11 10:00 PM, Ryosuke Niwa wrote:
>> On Tue, Aug 30, 2011 at 12:15 PM, Ryosuke Niwa<rniwa at webkit.org>  wrote:
>>> 4. Jonas requested that we have manualTransact and managedTransact
>>> instead
>>> of single transact on undoManager for clarity.  I think this is a good
>>> idea
>>> but I'd rather settle the naming issue first.
>>  If we're making this change (presumably, automaticTransact and
>> manualTransact), then it seems odd that both of them take the Transaction
>> interface because "apply" is required while "unapply" and "reapply" are
>> ignored for automaticTransact, but they're all optional for
>> manualTransact.
>> Should we also split the interface into AutomaticTransaction interface and
>> ManualTransaction interface?
> That makes sense to me.

Same here.

/ Jonas

More information about the whatwg mailing list