[whatwg] translate attribute conflicts with http://www.winktoolkit.org/documentation/symbols/HTMLElement.html#translate
w3c at adambarth.com
Mon Mar 26 15:22:33 PDT 2012
On Mon, Mar 26, 2012 at 3:17 PM, Ian Hickson <ian at hixie.ch> wrote:
> On Mon, 26 Mar 2012, Adam Barth wrote:
>> WebKit recently implemented
>> http://www.whatwg.org/specs/web-apps/current-work/#attr-translate, but
>> that caused us to break orange.fr on mobile:
>> The problem is that
>> has a the following code:
>> if (wink.isUndefined(HTMLElement.prototype.translate))
>> HTMLElement.prototype.translate = HTMLElement.prototype.winkTranslate;
>> The web site expects HTMLElement.prototype.translate to be Wink's
>> translate function rather than the HTML translate attribute.
>> Would it make sense to change the name of the translate attribute to
>> avoid this conflict? Should we try to evangalize the Wink Toolkit to
>> change their code and everyone who uses Wink to update to the fixed
> How widely used is it? (In particular, how widely used is .translate()
> rather than .winkTranslate()?)
The documentation lists only .translate(), not .winkTranslate(), so I
would expect most folks using the library to use the former rather
than the latter.
> I don't mind changing the name, but it's unclear that there's a better
> name out there. It would be unfortunate to have to reserve the use of a
> name as generic as "translate" for a particular library.
> In any case we should definitely ask Wink to avoid unprefixed names.
> That's asking for trouble.
> Ian Hickson U+1047E )\._.,--....,'``. fL
> http://ln.hixie.ch/ U+263A /, _.. \ _\ ;`._ ,.
> Things that are impossible just take longer. `._.-(,_..'--(,_..'`-.;.'
More information about the whatwg