[whatwg] Canvas in Workers
ian at hixie.ch
Fri Nov 16 13:48:28 PST 2012
On Fri, 16 Nov 2012, Rick Waldron wrote:
> On Fri, Nov 16, 2012 at 4:11 PM, Ian Hickson <ian at hixie.ch> wrote:
> > On Fri, 16 Nov 2012, Rick Waldron wrote:
> > > On Fri, Nov 16, 2012 at 3:25 PM, Ian Hickson <ian at hixie.ch> wrote:
> > > >
> > > > var proxy = canvas.transferControlToProxy());
> > >
> > > <bikeshed>
> > >
> > > Proxy with a capital P is an API in ES6 for creating Proxy objects.
> > > While I recognize that this is obviously just a conceptual sketch of
> > > your idea and that you're merely following the camel case tradition, now
> > > is probably the best time to be informed of potential naming conflicts.
> > The word Proxy is used all over the place on the Web platform, I'm not too
> > worried about that. Right now the object returned above is "CanvasProxy",
> > which is the kind of proxy that it refers to. I'm certainly open to
> > another name, any suggestions?
> CanvasProxy is a fine disambiguation.
Do you think we should rename the method above to say that too?
"canvas.transferControlToCanvasProxy()" is a bit verbose. :-)
I had shortened it to just "canvas.transferControlToProxy" on the
assumption that the fact that it was called on a canvas would disambiguate
that it was a canvas proxy, but I'm certainly open to other suggestions.
Ian Hickson U+1047E )\._.,--....,'``. fL
http://ln.hixie.ch/ U+263A /, _.. \ _\ ;`._ ,.
Things that are impossible just take longer. `._.-(,_..'--(,_..'`-.;.'
More information about the whatwg