[whatwg] [canvas] Path object

Tab Atkins Jr. jackalmage at gmail.com
Tue Oct 2 15:00:29 PDT 2012

On Sat, Sep 22, 2012 at 9:17 PM, Elliott Sprehn <esprehn at gmail.com> wrote:
> I was looking at the canvas Path API and had some concerns. In
> particular it's inconsistent with the rest of canvas:
> We already have CanvasGradient and CanvasPattern in the global
> namespace, so this should probably be called CanvasPath.
> We also have createLinearGradient() and createPattern(), but this new
> thing is "new Path".
> Could we get some consistency here? Like adding new CanvasGradient()
> (or a createPath() method) to match up with Path and renaming this
> thing CanvasPath?

I think the SVGWG would be opposed to that - we rather like the Path
api and would appreciate being able to appropriate it for our own uses
(merging with the <path> API).

I'm fine with gradients/patterns moving to a plain constructor rather
than a factory method, though.


More information about the whatwg mailing list