[whatwg] New URL Standard

Alexandre Morgaut Alexandre.Morgaut at 4d.com
Tue Sep 25 15:31:49 PDT 2012

On 26 sept. 2012, at 00:14, David Sheets wrote:

> On Tue, Sep 25, 2012 at 2:13 PM, Glenn Maynard <glenn at zewt.org> wrote:
>> On Mon, Sep 24, 2012 at 7:18 PM, David Sheets <kosmo.zb at gmail.com> wrote:
>> The right approach is probably to expose the results in an object-like form,
>> as Tab suggests, but to store the state internally in a list-like format,
>> with modifications defined in terms of mutations to the list.

Isn't it what does the Web Storage API? In which each key can be found by an index using the key() method:


My concern is just that "key" should probably be named "getKey" to avoid name collision with parameter names

Alexandre Morgaut
Wakanda Community Manager

60, rue d'Alsace
92110 Clichy

Standard : +33 1 40 87 92 00
Email :    Alexandre.Morgaut at 4d.com
Web :      www.4D.com

More information about the whatwg mailing list