[whatwg] Canvas: compositing and blending operator as enumeration?

Dirk Schulze dschulze at adobe.com
Wed Jan 9 18:18:18 PST 2013


After all the discussions about winding rules and the new introduced enumeration for "nonzero" and "even odd", I wonder if the the compositing and blending modes should be two enumerations as well.

enum CanvasCompositingMode {


enum CanvasBlendingMode {

This wouldn't actually change the behavior or definition a lot, but might help to cleanup a bit. I am happy about other names if they are not good enough.


More information about the whatwg mailing list