[whatwg] Questions regarding Path object
lists at scratchdisk.com
Mon Jun 17 14:42:45 PDT 2013
On Apr 9, 2013, at 16:17 , Rik Cabanier <cabanier at gmail.com> wrote:
> I like the following naming scheme, as it is really short and already familiar for people from the Java world, but I can imagine that a prefix would be preferred.
> Path2D, Shape2D, Gradient2D, Matrix2D
> Path2d and Shape2d sound reasonable. I don't think there's a immediate need to harmonize gradients so we probably want to keep CanvasGradient.
Do you prefer the lowercase 'd' instead of the uppercase 'D'? I think most acronyms in JS are uppercased (e.g. JSON), so the latter seems more aligned with convention.
And what is required to get such a proposal through? I really think using 'Path' as a new global constructor at this point is a bad idea, and could cause quite a bit of trouble with apps out there.
More information about the whatwg