[whatwg] Proposal: createImageBitmap should return a "Promise" instead of using a callback

Tab Atkins Jr. jackalmage at gmail.com
Thu Jun 20 10:23:24 PDT 2013

On Thu, Jun 20, 2013 at 7:08 AM, Justin Novosad <junov at google.com> wrote:
> On Wed, Jun 19, 2013 at 10:18 PM, Anne van Kesteren <annevk at annevk.nl>wrote:
>> I think something like
>> interface ImageBitmap {
>>   static Promise create(ImageBitmapSource image, optional long sx,
>> long sy, long sw, long sh);
>> };
>> would be much nicer.
> I agree it would be nicer, but it seems less consistent with other existing
> APIs.

There's really no consistency here anyway, and the
"Interface.create()" idiom is pretty easy and nice.

I wonder - perhaps we can call the function "new"?  Dunno which name is better.


More information about the whatwg mailing list