[imps] Installinmg a local copy of validator.nu

Martin Sharratt Martin.Sharratt at uwe.ac.uk
Thu Dec 1 09:06:31 PST 2011


Thanks for the advice - I've had a breakthrough and now have a working validator.

There were two problems with the patched build script - the first was it seemed to be having checksum problems with files downloaded from kent.dl.sourceforge.net<http://kent.dl.sourceforge.net>.  I thought I'd fixed that by downloading the zip files manually and sticking them in the dependencies directory.  This seemed to have worked but the java failed to compile.  On checking deeper, I found that although the build script was happy that the zip files were there, it didn't unzip them which meant that there was a fair bit of source code missing.

After I unzipped the files, I ran into the second problem - difficulties downloading from s.validator.nu.

That turned out to be a proxy issue of some kind - we have to go through a proxy server to get to the Internet.  I've set all the variables and configuration files I could find with the correct proxy settings but it would appear the java command that runs the validator doesn't read them.    In desperation, I made a firewall hole for the server - http and https and it finally ran.

Still getting some strange results in the test phase - looks like there are some corrupt files - but the server starts and validates html5 code.

Now to integrate with the w3c markup validator!  BTW I'm running on a freshly built Debian 6.0 VM.

Thanks for your help

Martin S
From: alan johnson [mailto:alanmaceoin at gmail.com]
Sent: 01 December 2011 14:38
To: Martin Sharratt
Subject: Re: [imps] Installinmg a local copy of validator.nu


I also had some problems, but not two weeks of them!

I was unable to get validator.nu<http://validator.nu> running on CentOS6, (I think it didn't like the installed version of python) so heres what I did instead...

Installed Ubuntu Server (there are reports of success with Ubuntu) as a vm and had both w3c and nu validators running on it pretty quickly,
I installed the following packages: w3c-markup-validator, mercurial, subversion, openjdk-6-jre, openjdk-6-jdk, python2.6
Then followed the instructions at about.validator.nu#src<http://about.validator.nu#src>

All worked perfectly, the first build did take a while, but once it has all the deps downloaded it runs through pretty quickly (the patch helps).
Trying the Install in a fresh Ubuntu VM would help eliminate any problems that may exist with your system config.

http://s.validator.nu/html5/html5full.rnc also shows a 404 in my browser but loads perfectly when running the build script, I suspect my script is loading a local copy...

Can you confirm that you have

and a bucketload of other schemas in this folder?

A home proxy could be useful for emergencies where your work IP has been blacklisted (You'd have to ask the powers that be!!).

Main caveats I have found installing validator-nu:

 *   java_home not being set
 *   python version less than what is required - I have had success with 2.7.2+
 *   timeouts when downloading from w3c ( leave the build runing overnight )

Hope this helps!


On 1 December 2011 12:31, Martin Sharratt <Martin.Sharratt at uwe.ac.uk<mailto:Martin.Sharratt at uwe.ac.uk>> wrote:
> Hi Alan
> Thanks for this - it at least got the DTD's all though I'd got round the problem by downloading them at home where I don't seem to be blocked by w3.   However, I've still not managed to get a working installation.  The unpatched build script gives a 'build successful" message then eventually fails with an error:
> nu.validator.servlet.VerifierServletTransaction - Will load schema: http://s.validator.nu/html5/html5full.rnc
> Exception in thread "main" java.lang.ExceptionInInitializerError
>        at org.whattf.datatype.Html5DatatypeLibrary.createDatatype(Html5DatatypeLibrary.java:134)
>        ....
>        ....
> Caused by: java.lang.RuntimeException: java.net.ConnectException: Connection refused
>        at org.whattf.datatype.Charset.<clinit>(Charset.java:50)
> I note that the url http://s.validator.nu/html5/html5full.rnc fails with a 404 error
> The patched script seems to be having  difficulty with some checksums downloading from kent.dl.sourceforge.net<http://kent.dl.sourceforge.net>.  After I got round that by downloading the zipfiles directly and copying them to the dependencies directory, it again builds successfully only to fail with errors
> Exception in thread "main" java.lang.NoClassDefFoundError: nu/validator/servlet/Main
> Caused by: java.lang.ClassNotFoundException: nu.validator.servlet.Main
> I've been working on this for the best part of two weeks and seem to be getting nowhere and was coming to the conclusion that either the code or the dependencies or both were seriously broken.  Did you manage to get it working?
> Regards
> Martin Sharratt
> -----Original Message-----
> From: implementors-bounces at lists.whatwg.org<mailto:implementors-bounces at lists.whatwg.org> [mailto:implementors-bounces at lists.whatwg.org<mailto:implementors-bounces at lists.whatwg.org>] On Behalf Of AlanJ
> Sent: 30 November 2011 12:47
> To: implementors at whatwg.org<mailto:implementors at whatwg.org>
> Subject: Re: [imps] Installinmg a local copy of validator.nu<http://validator.nu>
> Hi Martin,
> There is a patch that helps get past that part of the install/build,
> see here:
> https://bitbucket.org/validator/build/issue/2/received-error-retrying
> It basically downloads a batch of DTDs as a zip when it can.
> After applying this patch my install,
> (and subsequent reinstalls) went much quicker.
> Regards,
> Alan.
> _______________________________________________
> Implementors mailing list
> Implementors at lists.whatwg.org<mailto:Implementors at lists.whatwg.org>
> http://lists.whatwg.org/listinfo.cgi/implementors-whatwg.org

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.whatwg.org/pipermail/implementors-whatwg.org/attachments/20111201/fcbe5c4c/attachment-0003.htm>

More information about the Implementors mailing list