[whatwg] hashchange only dispatched in history traversal
giecrilj at stegny.2a.pl
Sat Aug 11 10:00:37 PDT 2007
Originally the name after the hash was a bookmark, not a fragment, because
it would be defined on an anchor. I agree that until the new semantic makes
it to the common knowledge using the name "fragment" for the purpose may be
surprising for some developers.
From: whatwg-bounces at lists.whatwg.org
[mailto:whatwg-bounces at lists.whatwg.org] On Behalf Of Ian Hickson
Sent: Saturday, August 11, 2007 12:15 AM
To: Maciej Stachowiak
Subject: Re: [whatwg] hashchange only dispatched in history traversal
I kind of like onfragmentload but "fragment" seems to have connotations of
bits of documents rather than of fragment identifiers. I don't think it's
necessarily any clearer than "hash"... I don't know.
More information about the whatwg