[whatwg] hashchange only dispatched in history traversal

Maciej Stachowiak mjs at apple.com
Sat Aug 11 13:14:24 PDT 2007

On Aug 11, 2007, at 10:00 AM, Křištof Želechovski wrote:

> Originally the name after the hash was a bookmark, not a fragment,  
> because
> it would be defined on an anchor.  I agree that until the new  
> semantic makes
> it to the common knowledge using the name "fragment" for the purpose  
> may be
> surprising for some developers.

When was it called a bookmark? I'm pretty sure it has been called a  
fragment identifier back to at least the late '90s.

> Best regards
> Chris
> -----Original Message-----
> From: whatwg-bounces at lists.whatwg.org
> [mailto:whatwg-bounces at lists.whatwg.org] On Behalf Of Ian Hickson
> Sent: Saturday, August 11, 2007 12:15 AM
> To: Maciej Stachowiak
> Subject: Re: [whatwg] hashchange only dispatched in history traversal
> I kind of like onfragmentload but "fragment" seems to have  
> connotations of
> bits of documents rather than of fragment identifiers. I don't think  
> it's
> necessarily any clearer than "hash"... I don't know.

More information about the whatwg mailing list