[whatwg] hashchange only dispatched in history traversal
mjs at apple.com
Sun Aug 12 14:59:05 PDT 2007
On Aug 12, 2007, at 10:38 AM, Krzysztof Żelechowski wrote:
> Dnia sobota, 11 sierpnia 2007 22:14, Maciej Stachowiak napisał:
>> On Aug 11, 2007, at 10:00 AM, Křištof Želechovski wrote:
>>> Originally the name after the hash was a bookmark, not a fragment,
>>> it would be defined on an anchor. I agree that until the new
>>> semantic makes
>>> it to the common knowledge using the name "fragment" for the purpose
>>> may be
>>> surprising for some developers.
>> When was it called a bookmark? I'm pretty sure it has been called a
>> fragment identifier back to at least the late '90s.
> In the early '90s? And I did not say it was called a bookmark but
> it was like
> a bookmark semantically.
Apparently it's been called a fragment identifier for about as long as
the World Wide Web has existed. I don't know what you mean by "like a
bookmark semantically". It's no more or less like a bookmark than any
other part of a URI.
More information about the whatwg