[whatwg] Significant changes to globalStorage

Dave Camp dave.camp at gmail.com
Fri Jan 11 13:22:35 PST 2008

On Dec 10, 2007, at 5:46 PM, Ian Hickson wrote:

> I just checked in a change to make globalStorage far simpler -- I  
> dropped
> all the domain manipulation stuff, and made it same-origin instead.  
> I also
> dropped StorageItem and just made the Storage stuff return strings.

Perhaps the new globalStorage object should be renamed while making  
this change?  This will let us deprecate globalStorage a bit more  
gracefully (clients checking for its existence won't get an object  
that behaves differently than expected).

Perhaps "localStorage"?

That still won't help users of StorageItem.value, but it might be  
useful anyway.


More information about the whatwg mailing list