[whatwg] HTMLCanvasElement.toFile()

Henri Sivonen hsivonen at iki.fi
Fri Jan 8 01:44:05 PST 2010

On Jan 8, 2010, at 05:59, Jonas Sicking wrote:

> On Thu, Jan 7, 2010 at 5:27 PM, Shumpei Shiraishi
> <shumpei.shiraishi at gmail.com> wrote:
>> Hi.
>> I think the method name "toFile()" is missleading, because I agree to
>> the Maciej's openion.
>>> I don't think using File for temporary in-memory binary data, as opposed to a file on disk, makes sense.
>> So, how about changing the method name to "toBlob()" and signature as follows?
>> Blob toBlob(in optional DOMString type, in any... args);
> This doesn't address my concern that you won't know the mime type of
> the blob returned.

Image types can be reliably distinguished from the magic number, so having the MIME type isn't critical in that sense.

Henri Sivonen
hsivonen at iki.fi

More information about the whatwg mailing list