[whatwg] Proposal to extend registerProtocolHandler

Ojan Vafai ojan at chromium.org
Fri Jul 1 14:44:06 PDT 2011

Agree. This seems strictly superior. Just to bikeshed on the name a bit,
since this is hanging off the navigator object, the name should probably
mention something about protocols, protocolState()?

On Fri, Jul 1, 2011 at 2:25 PM, Michael Davidson <mpd at google.com> wrote:

> From my perspective on Gmail, I would prefer to know if the user hasn't
> registered because they declined previously or haven't been asked. If
> they've declined previously, then calling registerProtocolHandler() in
> today's UAs will not do anything. If I can't detect that state, then they'll
> keep clicking and I'll keep calling and they'll get frustrated.
> I'd prefer if isRegistered() was something like registeredState() and
> returned REGISTERED, DECLINED, or NOTASKED. Then I could make a UI that
> really reflects reality.
> Michael

More information about the whatwg mailing list