[whatwg] Proposal: Adding methods like getElementById and getElementsByTagName to DocumentFragments

Simon Pieters simonp at opera.com
Mon Oct 14 13:38:33 PDT 2013

On Thu, 10 Oct 2013 17:52:49 +0200, Glenn Adams <glenn at skynav.com> wrote:

>> You'd actually write "CSS.escape", so that's basically the longer,
>> different name. Is that sufficient?
> I don't want to bikeshed over this, but I was thinking of perhaps
> serializeIdent(), or escapeIdent().

The API is intended to be used for escaping CSS strings too. Also, I think  
most Web developers don't think in terms of CSS tokens.

Serialize seems a bit wrong since the input isn't an object.

Simon Pieters
Opera Software

More information about the whatwg mailing list