[imps] validator front end not talking to servlet

Rancid Iodine rancid.iodine at gmail.com
Wed Apr 18 06:03:27 PDT 2012

OK that sounds good. I always thought the 2 went hand in hand i.e. any
legacy w3c markup validator from v1.2 upwards (which I perceived as "the
front end"), and the valdiator.nu servlet, but if we can do away with the
legacy validator in view of duplication of functionality, all the better.

At this point then, I have stopped the apache which hosted the legacy
markup validator, and fired up the servlet on port 80 like so:

python build/build.py --port=80 --local run &

We can see it's listening:

[root at vp-w3c-validator12 tmp]# netstat -ltunp | grep 80
tcp        0      0 :::80                       :::*
LISTEN      4402/java

Even so, I am encountering the same problem as before: although it's
possible to telnet to port 80 on this host from wherever (btw I run the
servlet on port 80 as it's the "generally open" port in our network), it's
still not possible to browse port 80 on this host, not even from the local
machine using any command line browser like lynx, links or w3m.

As I now get a never-ending "HTTP request sent, awaiting response... ", the
next thing would be to try and diagnose the problem using tcpdump.

Can you think of any obvious reason the servlet would not reply to the http

In case anyone can spot anything, this is how it's going down:

[root at vp-w3c-validator12 checker]# python build/build.py --port=80 --local
run &
[1] 4436

[root at vp-w3c-validator12 checker]# java -XX:-DontCompileHugeMethods
-Xms131072k -Xmx131072k -XX:ThreadStackSize=2048 -classpath
www.iana.org/assignments/character-sets -Dorg.whattf.datatype.warn=true
-Dnu.validator.servlet.host.generic= -Dnu.validator.servlet.host.html5=
nu.validator.servlet.Main 80
2012-04-18 13:57:43.723:INFO::Logging to STDERR via
nu.validator.servlet.VerifierServletTransaction - Starting static
nu.validator.servlet.VerifierServletTransaction - Starting to loop over
config file lines.
nu.validator.servlet.VerifierServletTransaction - Finished reading config.
nu.validator.servlet.VerifierServletTransaction - Converted config to
nu.validator.servlet.VerifierServletTransaction - Prepared namespace array.
nu.validator.servlet.VerifierServletTransaction - Parsed doctype numbers
into ints.
nu.validator.servlet.VerifierServletTransaction - The cache path prefix is:
nu.validator.servlet.VerifierServletTransaction - Parsing set up. Starting
to read schemas.
nu.validator.servlet.VerifierServletTransaction - Will load schema:
nu.validator.servlet.VerifierServletTransaction - Will load schema:
nu.validator.servlet.VerifierServletTransaction - Will load schema:
nu.validator.servlet.VerifierServletTransaction - Will load schema:
nu.validator.servlet.VerifierServletTransaction - Will load schema:
nu.validator.servlet.VerifierServletTransaction - Will load schema:
nu.validator.servlet.VerifierServletTransaction - Will load schema:
nu.validator.servlet.VerifierServletTransaction - Will load schema:
nu.validator.servlet.VerifierServletTransaction - Will load schema:
nu.validator.servlet.VerifierServletTransaction - Will load schema:
nu.validator.servlet.VerifierServletTransaction - Schemas read.
nu.validator.servlet.VerifierServletTransaction - Reading spec.
nu.validator.servlet.VerifierServletTransaction - Spec read.
nu.validator.servlet.VerifierServletTransaction - Initialization complete.
2012-04-18 13:57:52.147:INFO::jetty-6.1.26
2012-04-18 13:57:52.271:INFO::Started SocketConnector at

[1]+  Stopped                 python build/build.py --port=80 --local run
[root at vp-w3c-validator12 checker]# netstat -ltunp | grep 80
tcp        0      0 :::80                       :::*
LISTEN      4436/java
udp        0      0       *

[root at vp-w3c-validator12 checker]# wget
--2012-04-18 13:58:14--
Connecting to connected.
HTTP request sent, awaiting response... ^C

[root at vp-w3c-validator12 checker]# wget
--2012-04-18 13:58:19--
Connecting to connected.
HTTP request sent, awaiting response... ^C

[root at vp-w3c-validator12 checker]# wget
--2012-04-18 13:58:33--
Connecting to connected.
HTTP request sent, awaiting response... ^C

[root at vp-w3c-validator12 checker]# wget http://localhost/html5/
--2012-04-18 13:58:49--  http://localhost/html5/
Resolving localhost... ::1,
Connecting to localhost|::1|:80... connected.
HTTP request sent, awaiting response... ^C

[root at vp-w3c-validator12 checker]# time wget http://localhost/html5/
--2012-04-18 13:59:01--  http://localhost/html5/
Resolving localhost... ::1,
Connecting to localhost|::1|:80... connected.
HTTP request sent, awaiting response... ^C

real    0m4.440s
user    0m0.002s
sys     0m0.003s

Many thanks,


On 18 April 2012 12:07, Michael[tm] Smith <mike at w3.org> wrote:

> Rancid Iodine <rancid.iodine at gmail.com>, 2012-04-17 17:57 +0100:
> > It's possible to telnet to this service on that port (or indeed whatever
> > other port xxx I make the servlet run on using "python build/build
> > --port=xxx --local run "),
> You should also be able to open http://localhost:8888 in your browser and
> you'll get the validator.nu UI.
> > but the markup validator "front end" seems to have a problem talking to
> > the servlet.
> Which front end? The front end is at http://localhost:8888
> > The problem is seen to be a "504 gateway timeout" according to the markup
> > validator, and shown thus:
> >
> > External Checker not available
> >
> > Checking the Document Type of this document requires the help of an
> > external tool which was either not enabled in this validator, or is
> > currently unavailable. Check in the validator's system configuration that
> > HTML5 Validator is enabled and functional.
> >
> > The error encountered was: 504 Gateway Time-out
> Ah. Those messages are not coming from the validator.nu backend.
> It seems like what you are doing is, you have an instance of the legacy W3C
> validator service installed (either through some package or from the
> sources at http://dvcs.w3.org/hg/markup-validator) and you are trying to
> get that to communicate with the separate validator.nu instance you've
> built and installed.
> If that's the case I can't help you, because I don't work on that code. The
> best places to get help are:
>  http://lists.w3.org/Archives/Public/www-validator/
>  http://lists.w3.org/Archives/Public/public-qa-dev/
> As far as I can see from what you've described, the validator.nu backend
> is
> working as expected. The problem is that your legacy W3C validator instance
> is not reaching it for some reason.
> FWIW, I'd recommend not running a legacy W3C validator instance at all.
> Just make the front end at http://localhost:8888 available. It's capable
> for checking HTML4 and XHTML1 documents, not just HTML5 docs. And it does a
> much better job of checking HTML4 and XHTML1 docs than the legacy W3C
> validator does.
>  --Mike
> --
> Michael[tm] Smith http://people.w3.org/mike
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.whatwg.org/pipermail/implementors-whatwg.org/attachments/20120418/dc6eab49/attachment-0003.htm>

More information about the Implementors mailing list